summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2016-12-02 21:05:10 -0700
committerEduardo Chappa <chappa@washington.edu>2016-12-02 21:05:10 -0700
commita6d2585047ced0f5c3ae200f0df189fb45ef8763 (patch)
treef8e57ac3c899f94210008c9a554de5a65614aebf /configure.ac
parent232f7094c81cf3e78918adc5d112cc39d268c784 (diff)
downloadalpine-a6d2585047ced0f5c3ae200f0df189fb45ef8763.tar.xz
* In Cygwin, installing Openssl does not install libcrypto-devel, so we
add a check for crypt.h to the configure script to check that this file is properly installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fafa819c..d032df7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:18 by chappa@washington.edu])
+AC_REVISION([Rev:19 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_normalize(m4_include(VERSION))],[chappa@washington.edu])
@@ -1452,6 +1452,11 @@ if test "x$alpine_SSLTYPE" != "xnone" ; then
AC_MSG_ERROR(crypto library NOT found)
exit 1
fi
+ AC_CHECK_HEADER(crypto.h, , [ alpine_CRYPTO_DEVEL="none" ])
+ if test "x$alpine_CRYPTO_DEVEL" = "xnone" ; then
+ AC_MSG_ERROR(crypto library file crypt.h NOT found. Install correspoding licrypt-devel package)
+ exit 1
+ fi
fi
if test "x$alpine_SSLTYPE" != "xnone" ; then