summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2020-04-11 22:28:56 -0600
committerEduardo Chappa <chappa@washington.edu>2020-04-11 22:28:56 -0600
commit47206e18c8eec0c9c284cb71381ae85ce36b2a3a (patch)
tree9bd54b6d44a20deba364bce077059072f898b804 /configure.ac
parentb50297779a4becb9ceca9c6b5b375d526fe3df78 (diff)
downloadalpine-47206e18c8eec0c9c284cb71381ae85ce36b2a3a.tar.xz
* Remove sleep of 5 seconds for mailcap programs that use the terminal
to display content. Suggested by Carl Edquist. In addition to remove configurable process table command and it corresponding sleep time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index cc3f01ea..7a510710 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,39 +106,6 @@ AC_ARG_WITH(host-stamp,
])
AC_SUBST([ALPINE_HOSTSTAMP], $ALPINE_hoststamp)
-dnl set ps command, this test is fragile, but it should mostly work
-ALPINE_psefcmd="/bin/ps auxww"
-ALPINE_psfailed="0"
-ALPINE_PSTEST="-"
-AC_ARG_WITH(ps-cmd,
- AS_HELP_STRING([--with-ps-cmd="CMD"],[Use this command to check running commands. Default: /bin/ps auxww]),
- [
- if test "x$withval" = "xno" -o "x$withval" = "xyes" -o "x$withval" = "x" ; then
- withval=$ALPINE_psefcmd
- fi
- ALPINE_PSTEST=`$withval | $EGREP "$withval" | $EGREP -v $EGREP`
- if test -n "$ALPINE_PSTEST" ; then
- ALPINE_psefcmd="$withval"
- else
- ALPINE_psfailed="1"
- if test "x$ALPINE_psefcmd" != "x$withval" ; then
- AC_MSG_WARN(failed command $withval. Trying $ALPINE_psefcmd)
- fi
- fi
- ])
-if test "$ALPINE_psfailed" = "1" -o "$ALPINE_PSTEST" = "-" ; then
- withval="$ALPINE_psefcmd"
- ALPINE_PSTEST=`$withval | $EGREP "$withval" | $EGREP -v $EGREP`
- if test -z "$ALPINE_PSTEST" ; then
- ALPINE_psfailed="1"
- else
- ALPINE_psfailed="0"
- fi
-fi
-if test "$ALPINE_psfailed" = "0" ; then
- AC_DEFINE_UNQUOTED([PSEFCMD], "$ALPINE_psefcmd", [ps command which outputs list of running commands])
-fi
-
dnl Set default locale dir.
case $host in
*apple-darwin*)