summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2013-09-21 18:45:27 -0600
committerEduardo Chappa <chappa@washington.edu>2013-09-21 18:45:27 -0600
commitc5bb25b1320af6cda4cc62ea9e15fbb03ee92026 (patch)
tree7edbf4ad7c92cac182112201293da92dff56d7bf /configure.ac
parent48e1f5018f9d324c1ebce3ea627db50fe03a2134 (diff)
downloadalpine-c5bb25b1320af6cda4cc62ea9e15fbb03ee92026.tar.xz
* Version 2.11.6
* Add /tls1, /tls1_1, /tls1_2 and /dtls1 to the definition of a server to use different ways to connect using ssl, for example {server.com/tls1} will attempt to connect to server.com at the ssl imap port (port 993) and establish a connection using TLSv1. These flags can be used in conjunction with the /ssl flag, the ssl flag is redundant. Conversely, however, the /ssl flag does not imply any of these flags; the /ssl flag means SSLv3 or, if not available, SSLv2 in the SSL port. * WebAlpine: add _GNU_SOURCE to make pubcookie build. * On my way to make 'make dist' and 'make distcheck' actually work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f00f8472..b47cb081 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl */
AC_PREREQ([2.69])
-AC_REVISION([Rev:3 by chappa@washington.edu])
+AC_REVISION([Rev:4 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
AC_INIT([alpine],[m4_normalize(m4_include(VERSION))],[chappa@washington.edu])
@@ -1490,6 +1490,7 @@ if test "x$alpine_REGEX" = "xyes" ; then
CPPFLAGS="$CPPFLAGS -I${top_builddir}/regex"
LDFLAGS="$LDFLAGS -L${top_builddir}/regex -lregex"
REGEX_BUILD=regex
+ REGEX_MAKEFILE="$REGEX_BUILD/Makefile"
fi
if test "x$with_pthread" != "xno" ; then
@@ -1874,7 +1875,7 @@ AC_SUBST([WEB_PUBCOOKIE_LINK])
AC_SUBST([AM_CFLAGS])
AC_SUBST([AM_LDFLAGS])
-AC_CONFIG_FILES([m4/Makefile po/Makefile.in regex/Makefile \
+AC_CONFIG_FILES([m4/Makefile po/Makefile.in $REGEX_MAKEFILE \
pith/osdep/Makefile pith/charconv/Makefile pith/Makefile \
pico/osdep/Makefile pico/Makefile \
alpine/osdep/Makefile alpine/Makefile \